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Class 4

1. Data Storage in Computer
Let’s Relate (Page-5)
	 I, O, S, I, S, I

Brush Up (Page-6)
	 (a) (iii), (b) (i), (c) (iv), (d) (ii)

Brush Up (Page-9)
	 1. Mouse, 2. (a) Random Access Memory, (b) Read Only Memory, (c) 

Compact Disc, (d) Digital Versatile Disc, (e) Universal Serial Bus

Exercise Session
A. 	 1. (c), 2. (d), 3. (a), 4. (c)
B.	 1. bit, 2. primary, 3. memory, 4. secondary, 5. circular
C.	 1. F, 2. F, 3. F, 4. F, 5. T
D.	 1. Raw facts and figures such as numbers, characters or symbols are 

known as data. Processed data is known as information. 2. The storage 
space in a computer is called memory. 3. Random Access Memory 
(RAM) – The working memory of a computer is called RAM. It stores the 
data, instructions and information temporarily. It is also called volatile 
memory, which means it loses its data once the power is turned OFF. 
When we turn OFF the computer, the information and data stored in 
this memory is lost. Read Only Memory (ROM) – It stores permanent 
instructions required for proper functioning of the computer system. It 
is a type of memory from which we can only read the information stored 
in it, but cannot write on it. Thus, it is also called permanent memory 
or non-volatile memory. Data and instructions stored in ROM are not 
lost even when the power is turned OFF. 4. We need some additional 
storage device to store the data. This storage device is called secondary 
memory. 5. Hard disk, CD and DVD.

Skill Task
	 1. Hard disk
	 2. CD-ROM drive
	 3. 4, 3, 1, 2
	 4. Across : A. BIT, C. PEN DRIVE, D. COMPACT DISC, G. BIOS
	      Down : B. INFORMATION, E. CIRCULAR, F. SECONDARY

2. More on Windows 10
Let’s Relate
	 This PC, Documents, Recycle Bin, Start Button
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Brush Up (Page-18)
	 Do it yourself.

Brush Up (Page-21)
	 1. (a), 2. (b), 3. (b), 4. (a)

Exercise Session
A. 	 1. (c), 2. (d), 3. (b), 4. (a), 5. (b)
B.	 1. Windows, 2. subfolder, 3. current, 4. Paste, 5. Cut
C.	 1. F, 2. T, 3. F, 4. T, 5. F
D.	 1. When we click the Start button, the Start menu opens. The Start 

menu has two panes. The left pane displays an alphabetical list of all 
the programs installed on our computer. The right pane contains tiles. 2. 
File Explorer is also known as Windows Explorer. It is a core part of the 
operating system. It is available on the taskbar. When we click on it, it 
opens a window which has two panes: right pane and left pane. 3. A file 
is a collection of data or information stored in the computer memory. 
A folder is a type of container that holds the files and subfolders.  
4. Copying a file or a folder means creating a copy of it and placing it 
at another location. Copying does not remove the original file or folder 
from its location. Moving a file or a folder means shifting the file/folder 
from its current location to another location. Moving removes the file 
from the original location. 5. All the files and folders that we delete are 
moved to the Recycle Bin. If we delete a file/folder by mistake, we can 
restore it from the Recycle Bin.

Skill Task
	 1. (a) (ii), (b) (v), (c) (iii), (d) (i), (e) (iv)
	 2. (a) FILE, (b) FOLDER, (c) FILE EXPLORER, (d) RECYCLE BIN, (e) LIVE 

TILES

3. Working with Objects in MS Word 2016
Let’s Relate (Page-26)
	 (a) Center align, (b) Left align, (c) Superscript, (d) Bulleted list,
	 (e) Uppercase, (f) Font style

Exercise Session
A. 	 1. (c), 2. (c), 3. (b), 4. (a), 5. (a)
B.	 1. Insert Picture, 2. resize, 3. Text Outline, 4. Picture Layout, 5. Symbols
C.	 1. F, 2. T, 3. F, 4. T, 5. T
D.	 1. To insert a picture, follow these steps: Step 1 : Place the cursor where 

you want to insert the picture. Step 2 : Click on Insert tab. Select the 
Pictures option in the Illustrations group. Step 3 : The Insert Picture 
dialog box will appear. Step 4 : Browse to the location of the picture 
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you wish to insert. Select the picture. Step 5 : Click on the Insert button. 
The selected picture will appear in the document. 2. This option helps 
us to cut the unwanted part of a picture. 3. Stretching is used to stretch 
drawing objects either larger or smaller. Cropping a picture means 
removing unwanted part from the picture. 4. WordArt is the special 
effect in Word to change the appearance of the text. The WordArt 
gallery includes various designs that can be used to create attractive 
looking text. We can edit or format the WordArt text by changing the 
styles, fill colour, line colour and other settings. 5. To insert shapes, 
follow these steps: Step 1: Click on the Insert tab. Click on the drop-
down arrow below the Shapes option in the Illustrations group.  
Step 2: Select the desired shape. Step 3 : Click and drag the mouse to 
draw the shape and release the mouse button when the shape is of the 
desired size. 6. To change fill colour, outline colour and thickness of the 
shape, follow these steps: Step 1 : Select the shape. Step 2 : Click on 
the Format tab. Step 3 : Click on Shape Fill option. A drop-down menu 
appears. Select the desired colour. Step 4 : Click on the Shape Outline 
option. A drop-down menu appears. Select the outline colour and 
weight from the drop-down menu. 7. Text Fill : Fill the text with a solid 
colour and gradient. Text Outline : Customise the outline of our text 
by choosing the colour, width and line style. Text Effects : Add a visual 
effect such as Shadow, Reflection, Glow, etc. 8. To insert symbol and 
character, follow these steps: Step 1 : Place the cursor at the position 
where the symbol is to be inserted and click on the Symbol option on 
the Insert tab in the Symbols group. Step 2 : To add a symbol that is not 
present in the list, select the More Symbols option. The Symbol dialog 
box will appear on the screen.Step 3 : Choose a symbol from the list and 
click on the Insert button. To get more symbols, click on the Font drop-
down arrow. Step 4 : Click on the Cancel button to close the dialog box.

Skill Task

	 1.	 (a) WordArt, (b) Symbols, (c) Shapes
	 2. and 3. Do it yourself.

4. More Features of Word 2016
Let’s Relate (Page-38)
	 1. calculator, 2. information, 3. processor, 4. communication

Brush Up (Page-42)
Stories are always a favoured area for students that call their love and 
interest. This is one of the reasons why teachers use this as a gadget 
to push them in many areas.
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Exercise Session
A. 	 1. (c), 2. (c), 3. (a), 4. (c)
B.	 1. spell check, 2. Thesaurus, 3. Review, 4. Layout, 5. centimetre
C.	 1. F, 2. T, 3. T, 4. F, 5. F
D.	 1. Find tool is used to search for a word or text in a document. Replace 

tool replaces a specific word or text in a document. 2. Step 1 : Select 
the word. Step 2 : Click on Thesaurus option in Proofing group on the 
Review tab. Step 3 : The Thesaurus Pane opens on the right side of the 
window. It displays a list of synonyms and antonyms for the selected 
word. Step 4 : Click the drop-down arrow of the suggested word and 
select Insert or Copy. 3. To find a specific word and replace it with other 
word, follow these steps: Step 1 : Click on Replace option in the Editing 
group on the Home tab. Find and Replace dialog box appears. Step 2 
: Enter the text to search in the Find what box and the new text to 
replace the existing text in the Replace with box. Step 3 : Click on either 
of the following options : Replace, Replace All, Find Next. Step 4 : Click 
on Close or   button to close the dialog box. 4. To change paragraph 
spacing, follow these steps: Step 1 : Click on the Layout tab. Step 2 : 
Click on the Before and After boxes under Spacing in Paragraph group. 
Step 3 : Click on the arrows in the boxes to choose the required spacing. 
5. You might have seen that the news articles written in newspaper are 
arranged in a specific manner. This is done with the help of Columns 
option in Word. 6. A page break starts a new page. A column break 
starts a new column.

Skill Task
	 1. (a) Find and Replace, (b) The red wavy lines indicate spelling mistakes. 

This can be corrected using Spelling and Grammar option. (c) Thesaurus
	 2. Do it yourself.

5. Introduction to PowerPoint 2016
Let’s Relate (Page-52)
	 2, 4, 3, 1

Brush Up (Page-55)
	 1. slides, 2. Status Bar, 3. top, 4. slide show

Brush Up (Page-61)
	 Do it yourself.

Exercise Session
A. 	 1. (b), 2. (b), 3. (b), 4. (c), 5. (a)
B.	 1. left, 2. thumbnail, 3. Title slide, 4. F5, 5. corners
C.	 1. F, 2. F, 3. T, 4. T, 5. F
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D.	 1. A single page of the presentation is called slide. 2. A presentation is 
an interesting way of describing something to an audience. 3. (i) Title 
Bar : Title bar is located at the top of the PowerPoint window. It shows 
the name of the current presentation and the name of the program. It 
also contains the Quick Access toolbar on the left and control buttons 
on the right. (ii) Quick Access Toolbar : It contains commonly used 
command buttons such as Save, Undo, Redo and Slide Show. (iii) Ribbon 
: It is located below the title bar. A ribbon is made up of Tabs. Each tab 
contains many commands arranged in different groups. (iv) Slides Pane 
: The slides pane is located on the left side of the window. It shows the 
thumbnail of each of the slides in the presentation. (v) Slide Area : It 
displays the active slide. 4. To add a slide, follow these steps: Step 1 : 
Click on the drop-down arrow next to the New Slide option in the Slides 
group on the Home tab. A list of available slide layouts is displayed. Step 
2 : Choose the Title and Content layout for the second slide. A new slide 
gets added to the presentation. Step 3 : Enter the required information 
in the placeholders on the new slide. 5. To delete a slide, follow these 
steps : Step 1 : Right-click on the slide in Slides pane which you want to 
delete. Step 2 : From the pop-up menu, choose the Delete Slide option. 
The slide will be deleted.

Skill Task
	 1. Click on the Slide Show tab and click on From Beginning. This will 

start the slide show from the very start slide.
or

	 Click on the Slide Show button on the status bar. This will start the slide 
show from the current slide. 

	 2. To change the slide layout, right-click on the slide and select Layout 
option. 

	 3. (a) (ii), (b) (iii), (c) (iv), (d) (i) 4. F5; Page Down, Enter; P; ESC; Delete

6. More About the Internet
Let’s Relate (Page-68)
	 1. (), 3. (), 5. (), 6. ()

Brush Up (Page-70)
	 1. World Wide Web, 2. linked, 3. Uniform Resource Locator, 4. link

Exercise Session
A. 	 1. (a), 2. (b), 3. (b), 4. (d)
B.	 1. linked, 2. website, 3. downloading, 4. tab
C.	 1. F, 2. T, 3. T, 4. T
D.	 1. The term Internet is a short form of International Network. It is 

the communication system of a network of millions of computers 
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connected with each other across the globe. 2. (i) World Wide Web 
(www) : The World Wide Web is an important part of the Internet. The 
World Wide Web refers to the largest collection of information in the 
form of websites on the Internet. The information can be a combination 
of text, graphics, audio, video, etc. (ii) Web Page : A web page is the 
basic unit of every website. A web page is created using a language 
called HTML (Hyper Text Markup Language). (iii) Web Browser : A web 
browser is a software that allows to view page on the World Wide 
Web. Some examples of web browsers are Google Chrome, Firefox, 
Microsoft Edge, Opera and Safari. (iv) Website : A website is a collection 
of linked web pages. The first page of a website is called the home page. 
3. The Internet was started as ARPANET (Advanced Research Project 
Agency Network) in 1960s. The US defence department established 
an agency for research and analysis in the field of defence. Later on, 
the US government opened ARPANET for educational purposes. Many 
universities and institutions started using this network of computers. 4. 
Microsoft Edge is the default web browser in the Windows10 operating 
system. Parts of Microsoft Edge— (i) Tab : In Microsoft Edge, website 
opens in a tab. If we want to open a new website, we must  first open a 
new tab through the New tab (+) button. (ii) Back Button : This button 
is used to view a previously visited web page. (iii) Forward Button : This 
button is used to view next visited web page.

Skill Task
	 1. (a) INTERNET, (b) SEARCH ENGINE, (c) HYPERLINK, (d) MICROSOFT 

EDGE
	 2. Do it yourself.

7. More on Scratch 3
Let’s Relate (Page-76)
	 move 10 steps, turn  15 degrees, go to random position,  

say Hello!
Brush Up (Page-80)
	 1. blue, 2. purple, 3. magenta, 4. amber, 5. yellow
Exercise Session
A. 	 1. (a), 2. (b), 3. (a), 4. (b), 5. (a)
B.	 1. Event, 2. C, 3. magenta, 4. trail, 5. 360
C.	 1. T, 2. F, 3. T, 4. T, 5. F
D.	 1. Stack Blocks : These blocks have a bowl shape cut at the top-left 

corner and a bump at the bottom-left corner. Some stack blocks are 
direct functions, while some contain values that can be changed.
Reporter Blocks : A reporter block is a code block that has either rounded 
or angled sides and is designed to provide information for other code 
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blocks to process. 2. This block moves the sprite to a specified x and y 
position on the stage. 3. These blocks are used to draw a trail as the 
sprite moves on the stage. 4. Erase all 5. Stamp block creates a duplicate 
copy of the current sprite. The image is stamped on the stage.

Skill Task
	 1. (a) Triangle, (b) Square, (c) Pentagon, (d) Hexagon, (e) Heptagon,  

(f) Octagon 

	 2. 80   3. 

8. Evolution of Artificial Intelligence
Let’s Relate (Page-87)
	 Do it yourself.

Exercise Session
A. 	 1. (c), 2. (b), 3. (a), 4. (b), 5. (c)
B.	 1. 1943, 2. Dartmouth, 3. decision-making, 4. Deep Blue, 5. rovers
C.	 1. T, 2. F, 3. F, 4. T, 5. F
D.	 1. Artificial Intelligence is an ability of a machine to think and learn.  

2. Alan Turing was an mathematician who pioneered machine learning 
in 1950 . 3. WABOT was the first intelligent humanoid robot. WABOT 
walked with his lower limbs and was able to grip and transport objects 
with his hands. 4. A smart speaker Google Home was released by Google, 
which uses AI to act as a personal assistant. 5. Microsoft launched 
Kinect for Xbox 360, the first gaming device that tracked human body 
movement using a 3D camera and Infrared detection.

Skill Task
	 1. (i) (d), (ii) (a), (iii) (c), (iv) (b)
	 2. (a) WABOT, (b) SOPHIA, (c) ALEXA, (d) CORTANA, (e) SIRI
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