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Class 6

1. Advanced Features of MS PowerPoint 2016
Let’s Relate (Page-5)
	 Do it yourself.

Brush Up (Page-12)
	 1. Table, 2. Audio, 3. Video, 4. Hyperlink
Exercise
A. 	 1. (b), 2. (c), 3. (d), 4. (c), 5. (b)
B.	 1. Table, 2. sound, 3. Online video, 4. Audio Styles, 5. Action
C.	 1. F, 2. T, 3. F, 4. F, 5. F
D.	 1. We can insert Excel Spreadsheet in a PowerPoint, which looks like a 

table. To insert Excel Spreadsheet, follow the given steps:  Step 1 : Place 
the cursor where we want the table to appear. Step 2 : Click on the 
Insert tab. Select the Table button and click on the Excel Spreadsheet 
option. Step 3 : Now, the Excel Spreadsheet will appear on the screen. 
Step 4 : Place the insertion point in the cell where we want to enter the 
data. Step 5 : After entering the data in spreadsheet, click outside the 
spreadsheet. We will notice the table will be inserted on the slides. 2. 
To add our own sound in the presentation, follow the given steps : Step 
1 : Select the slide where we want to insert the recorded sound. Step 2 
: Select the Insert tab. Click the Audio drop-down arrow in the Media 
group. Step 3 : Click the Record Audio option from the drop-down 
menu. Step 4 : The Record Sound dialog box appears. Step 5 : Type a 
name for our audio file in the Name field. Step 6 : Click on the Record 
button to start recording, and when we have finished the recording, 
click on the Stop button. Step 7 : To listen to the recorded sound, click 
on the Play button. Step 8 : Click on OK. A small speaker icon will appear 
on the slide. Step 9 : During the Slide Show, click on the Speaker icon 
to listen to the recorded sound. 3. To insert a video file from Internet, 
follow these steps : Step 1 : Select the slide where you want to insert 
the video clip. Step 2 : Select the Insert tab. Click the Video drop-down 
arrow in the Media group. Step 3 : Select the Online Video option from 
the drop-down list. The Insert Video dialog box appears. Step 4 : Click 
on the YouTube icon and type the keywords for the video you want 
to add. Step 5 : Select the video and click on Insert. Step 6 : Wait a 
few minutes for your video to load and when loaded, play the video.  
4. Action buttons are some built-in button shapes which can be added 
to a presentation to link them to the another slides, files, web pages and 
e-mail addresses. Action button works like the hyperlink.	 5. To remove 
a hyperlink, follow the given steps: Step 1 : Right-click the hyperlink. 
Step 2 : Click Remove Hyperlink.
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2. More on Excel 2016
Let’s Relate (Page-17)
	 1. Formula Bar, 2. Name Box, 3. Toolbar, 4. Worksheet, 5. Status Bar,  

6. Title bar

Brush Up (Page-23)
	 1. Top Align, 2. Center Align, 3. Bottom Align, 4. Left Align

Exercise
A. 	 1. (a), 2. (a), 3. (b), 4. (d), 5. (c)
B.	 1. Formatting, 2. font, 3. right, 4. Splitting, 5. four
C.	 1. T, 2. T, 3. F, 4. T, 5. F
D.	 1. Using the Home tab, most of the formatting effects can be applied to 

the text in the document. Some of them are as follows : • We can make 
the text bold, italic and underline. • We can increase or decrease the 
indent. • We can change the font type, size, colour and apply border, 
etc. • We can align the text horizontally or vertically. • We can merge 
or split cells. 2. Alignment is the setting of text flow or image relative 
to cell edges. In Excel, we can align text horizontally and vertically. Text 
alignment options are present under Home tab. 3. To delete columns, 
follow the given steps: Step 1 : Select the column header and click the 
Delete drop-down button in the Cells group on the Home tab. Choose 
the Delete Sheet Columns option. Or Right-click on the column header, 
which we want to delete. Select the Delete option. Step 2 : The selected 
column will be deleted and the contents lying to the right of this column 
will shift left by one column. 4. To change the column width, follow 
the given steps: Step 1 : Select the column(s) that we want to change.   
Step 2 : On the Home tab, in the Cells group, click Format. Step 3 : Under 
Cell Size, click Column Width option in the appeared drop-down menu. 
Step 4 : In the Column Width dialog box, type the value that we want. 
Click OK. 5. Excel follows general mathematical rules for calculations, 
which is Parentheses, Exponents, Multiplication, Division, Addition, 
Subtraction, or the acronym PEMDAS. Using parentheses allows us to 
change that calculation order. For doing calculations in an Excel cell 
we need to use arithmetic operators. We can easily get the result of a 
calculation if we follow these rules properly.

3. Formulas and Functions in Excel 2016
Let’s Relate (Page-33)
	 1. WORKBOOK, 2. FORMULA, 3. GENERAL, 4. OPERATOR

Brush Up (Page-40)
	 1. 49, 2. 343, 3. 247, 4. –16
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Exercise
A. 	 1. (a), 2. (a), 3. (c), 4. (c), 5. (a)
B.	 1. cell reference, 2. dollar, 3. range, 4. SUM(), 5. TODAY()
C.	 1. T, 2. T, 3. T, 4. T, 5. T
D.	 1. Using range names in Excel allows us to quickly navigate to 

areas of our worksheet and makes formulas much easier to create.  
2. Functions are the pre-designed formulas in Excel to perform both 
simple and complex calculations. Functions save time and eliminate the 
chance to write wrong formulas. The functions consist of two parts: the 
function name and its arguments. The arguments are included within the 
round brackets. 3. Rules to Enter a Function : (i) Functions must begin 
with = sign. (ii) Function name must be a valid Excel name. (iii) Function 
must be followed by opening and closing parenthesis. (iv) Parenthesis 
contain arguments within it. If there are more than one argument, then 
they should be separated by comma. 4. Absolute reference : This type 
of reference is used when we do not want to change the address of the 
cell while copying the formula to another cell. $A$10 is an example of 
absolute reference. Mixed reference : In this type of reference, either 
the row number is fixed or the column name is fixed. $A10 or A$10 is an 
example of mixed reference. 5. This is a conditional function. It returns 
one value, if a condition we specify evaluates to True, and another value 
if that condition evaluates to False.

4. Introduction to Adobe Animate CC 2018
Let’s Relate (Page-47)
	 Movie Name–Puss in Boots : The Last Wish 
	 Characters–Perrito, Puss in Boots
Brush Up (Page-51)
	 1. Stage, 2. Ink Bottle tool, 3. New Document dialog box, 4. Pencil tool

Exercise
A. 	 1. (c), 2. (a), 3. (d), 4. (b), 5. (a)
B.	 1. animations, graphics, 2. Timeline, 3. Selection, 4. Fill, 5. Merge 

Drawing Mode
C.	 1. F, 2. T, 3. F, 4. T, 5. F
D.	 1. To create a document in Adobe Animate CC, follow the given steps: 

Step 1 : Click on the File → New option from the menu bar. The New 
Document dialog box opens. Step 2 : Select the General tab, click 
the ActionScript 3.0 option from the Type section. Step 3 : Now set 
the dimensions for the Stage by entering new pixel values for the 
Width and Height on the right side of New Document dialog box.  
Step 4 : Choose the Background color as we desired. Here we are 
selecting white background. Step 5 : Click on the OK button. A new 
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document will be created in Animate CC 2018 . 2. The Tools panel has 
all the tools that we can use to create or modify drawings and text. We 
will note that few tools have a small triangle at their bottom-right end. 
When we click this triangle, a sub menu appears with more similar tools. 
3. Gradient fill is a multicolor fill in which one color gradually changes 
into another color. Animate CC lets us apply up to 15 color transitions 
to a gradient. 4. There are three type of symbols in Animate: (i) Movie 
Clip Symbol : A movie clip symbol is used to reusable parts of a movie. 
In this symbol, we can apply color settings, blending modes and filters. 
(ii) Button Clip Symbol : A button clip symbol is used to create a user 
interface to perform various actions like starting, stopping, etc. In this 
symbol, we can apply color settings, blending modes and filters. (iii) 
Graphic Symbol : A graphic symbol is a static object, like a background 
image or text. In this symbol, we cannot apply color settings, blending 
modes and filters. 5. Object drawing mode creates drawing objects. 
Drawing objects do not merge when overlaid over each other. Hence, 
when we move the objects apart, they look the same as they were 
originally. When the Object Drawing mode is turned off, the Merge 
Drawing mode becomes active. This is the default drawing mode in 
Animate. When we make overlapping shapes, the shape above cuts 
over the overlaid portion of the lower shape.

5. Introduction to HTML 5 and CSS
Let’s Relate (Page-60)
	 1. Yahoo, 2. Flipkart, 3. Facebook, 4. Amazon

Brush Up (Page-65)
	 1. head, 2. title, 3. body, 4. html

Exercise
A. 	 1. (b), 2. (b), 3. (b), 4. (c), 5. (b)
B.	 1. markup, 2. Text, 3. Tags, 4. Empty, 5. Bgcolor
C.	 1. T, 2. T, 3. T, 4. T, 5. T
D.	 1. HTML stands for HyperText Markup Language. It is a markup language 

that describes the structure of the web pages. It allows us to create web 
pages that contain paragraphs, headings, links and block quotes. Some 
of the important characteristics of HTML are: (i) It is easy to understand 
and modify. (ii) It is platform independent language. (iii) It allows us 
to build tables. (iv) It allows us to add a link on the web page. 2. In 
HTML, commands are known as tags. Tags describes how web page is 
displayed. All HTML tags are enclosed within the angle bracket (<>). An 
attribute is a special keyword used inside the tag to specify additional 
information about the tag such as alignment, font color, size of the 
text, etc. 3. An HTML editor is a specialized software used to create and 
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edit web pages. There are mainly two types of HTML editors WYSIWYG 
Editor (eg. Adobe Dreamweaver) and Text Editor (eg. Notepad). 4. The 
<Head> tag contains the title of the document. The content between the 
opening and the closing of the <Head> tag is not displayed in the web 
page. 5. Cascading Style Sheet(CSS) is used to set the style in web pages 
that contains HTML elements. It sets the background color, font-size, 
font-family, color, etc. property of elements on a web page. Using CSS, 
we can specify a number of style properties for a given HTML element. 
Each property has a name and a value, separated by a colon(:). Each 
property declaration is separated by a semi colon(;).

6. Cyber Safety and Threats
Let’s Relate (Page-71)
	 1. Hypertext Transfer Protocol, 2. Information Technology, 3. Uniform 

Resource Locator, 4. Advanced Research Projects Agency

Brush Up (Page-73)
	 1. (c), 2. (a), 3. (d), 4. (b)

Exercise
A. 	 1. (a), 2. (a), 3. (c), 4. (b), 5. (b)
B.	 1. Viruses, worms, 2. Plagiarism, 3. Cyberbullying, 4. Cyber safety,  

5. Anti-virus
C.	 1. F, 2. T, 3. T, 4. T, 5. T
D.	 1. Cyber threat is a malicious act that seeks to damage data, steal data, 

or disrupt digital life in general. 2. Viruses can replicate and spread to 
other systems by simply attaching themselves to the computer files. 
Worms are also self-replicating, just like viruses, but they do not need 
to get attached to another program to replicate. 3. Cyberbullying is the 
use of technology to harass, threaten, embarrass, or target another 
person. It includes photos, messages, or pages that don’t get taken 
down, even after the person has been asked to do so. 4. Software 
piracy is the unauthorized use, copying or distribution of copyrighted 
software. It may take many forms, including unauthorized copying of 
software programs purchased legitimately, sometimes known as “end-
user” piracy, which is illegal. 5. Password protection is a security process 
that protects information accessible via computers that needs to be 
protected from certain users. Password protection allows only those 
with an authorized password to gain access to certain information.  
• Use at least twelve characters. • Use a combination of upper and 
lower-case letters and at least one number. • Include at least one 
character that isn’t a letter or number, like !, # or $. • Use a series of 
letters that only make sense to you, like the first letters of each word 
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in a sentence. • Use different passwords for different accounts. • Use 
multi-factor authentication (MFA).

7. Programming Basics
Let’s Relate (Page-78)
	 1. 19, 2. 0 .625, 3. 3125, 4. 93

Brush Up (Page-80)
	 1  3  5  4  2  6

Exercise
A. 	 1. (b), 2. (b), 3. (a), 4. (b), 5. (c)
B.	 1. oval-shaped, 2. Connectors, 3. Computer, 4. Assembler, 5. 3G language
C.	 1. T, 2. T, 3. F, 4. T, 5. T
D.	 1. Programming is the process of writing instructions by a programmer 

to solve any problem or do any work on computer. 2. Flowcharts help 
programmers develop the most efficient coding because they can 
clearly see where the data is going to end up. 3. Following are some 
basic symbols that are used while making a flowchart: Start/Stop Box– 
The oval-shaped symbol indicates the beginning or end of a flowchart. 
Input/Output Box– This box is used to indicate the input or the output 
data. It is shaped like a parallelogram. Processing Box– The rectangle 
shaped box is used to show the processing step. Processing involves 
performing an operation such as addition, subtraction, etc. Decision 
Box– This box is shaped like a rhombus. It is used when we have to 
make a decision. A decision always involves a condition, depending on 
which an instruction will either be executed or not. Flow Line– Flow 
lines indicate the process direction. Each flow line usually connects two 
blocks. Flow lines can be straight lines, uni-directional arrow, or both-
sided arrows, representing different kinds of connections between 
the steps. Connector– A connector is used to show a jump from one 
point in the process flow to another. It connects different parts of a 
flowchart that are split between pages. 4. A low-level language is 
a programming language that deals with a computer’s hardware 
components and constraints. Low-level languages are divided into two 
categories: Machine Language and Assembly Language 5. Interpreter– 
An interpreter converts a program written in high-level language into 
machine language program line by line. It displays error of one line 
at a time and goes to the next line only after correction of that error 
and does not proceed till the error is rectified. Compiler– A compiler 
converts the entire HLL program into machine language at once and 
also displays errors for the whole program together.
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8. Introduction to Python Programming
Let’s Relate (Page-88)
	 1. C++, 2. Blue J, 3. Quick Basic

Brush Up (Page-93)
	 1. SYNTAX, 2. COMMENT, 3. INTERPRETER, 4. VARIABLE

Exercise
A. 	 1. (b), 2. (c), 3. (b), 4. (a), 5. (d)
B.	 1. Comments, 2. 35, 3. Interactive, 4. explicit, 5. .py
C.	 1. T, 2. T, 3. F, 4. F, 5. T
D.	 1. Python is a high-level, interpreted, general-purpose programming 

language. It was created by Guido van Rossum, and released in 1991 . 
It is used for web development (server-side), software development, 
mathematics and system scripting. 2. Arithmetic operators are used 
with numeric values to perform common mathematical operations. The 
arithmetic operators are described in the following table :

Operators Meaning Example A = 10; B = 6 Output
+ Addition A + B 16
– Subtraction A – B 4
* Multiplication A * B 60
/ Division A / B 1
% Modulus A % B 4
** Exponentiation A ** B 1,000,000
// Floor or Integer Division A // B 1

	 3. Interactive Mode is a command line shell which gives immediate 
result for each statement, while running previously typed statements 
in active memory. Interactive mode of working means you type the 
command- one command at a time, and the Python executes the given 
command there and then gives you output in interactive mode. Script 
Mode in Python is where we first write the Python program inside a 
script file and execute it after that. In the Script Mode, we can view the 
code anytime that we have written inside the file, and we can modify 
it before executing it next time. 4. Python supports various data types. 
These data types defines the operations possible on the variables and 
the storage method. Below is the list of standard data types available in 
Python:

		  Text Type :			   str
		  Numeric Types :		  int, float, complex
		  Sequence Types :		 list, tuple, range
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		  Mapping Type :		  dict
	 	 Set Types :	 	 set, frozenset
		  Boolean Type :		  bool
		  Binary Types :		  bytes, bytearray, memoryview
		  None Type :		  NoneType
	 5. Comments are the lines in the code that are ignored by the interpreter 

during the execution of the program. Comments enhance the readability 
of the code and help the programmers to understand the code very 
carefully.

9. Artificial Intelligence (AI) and its Approaches
Let’s Relate (Page-103)
	 1. Sophia, 2. Aibo, 3. Unimate, 4. Atlas, 5. Ameca

Brush Up (Page-106)
	 1. Alexa, 2. Robot, 3. Sophia, 4. Self-driven cars
Exercise
A. 	 1. (c), 2. (a), 3. (b), 4. (c), 5. (a)
B.	 1. Artificial Intelligence, 2. strong, 3. Agent, 4. physical, 5. Self-aware
C.	 1. T, 2. F, 3. F, 4. T, 5. T
D.	 1. Artificial intelligence is the simulation of human intelligence processes 

by machines, especially computer systems. 2. In Artificial Super 
Intelligence, intelligent systems of machines will surpass intelligence of 
humans, and can perform any task better than even humans. 3. The 
task of AI is to design an agent program which implements the agent 
function. The structure of an intelligent agent is a combination of 
architecture and agent program. It can be viewed as:

Agent = Architecture + Agent Program
	 Following are the main three terms involved in the structure of an 

AI agent: Architecture : Architecture is machinery that an AI agent 
executes on. Agent function : Agent function is used to map a sequence 
of perceptions into an action. Agent program : Agent program is an 
implementation of agent function. An agent program executes on the 
physical architecture to produce function. 4. PEAS is a type of model on 
which an AI agent works upon. When we define an AI agent, then we 
can group its properties under PEAS representation model. It is made 
up of four words:

	 P : Performance measure		  E : Environment
	 A : Actuators				   S : Sensors
	 Here performance measure is the objective for the success of an agent’s 

behaviour.
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		  PEAS for self-driving cars:
		  The representation of PEAS for self-driving cars will be:
		  Performance : Safety, time, legal drive, comfort
		  Environment : Roads, other vehicles, road signs, pedestrian
		  Actuators   : Steering, accelerator, brake, signal, horn
		  Sensors 	    : �Camera, GPS, speedometer, odometer, 

accelerometer, sonar.
	 5. There are four types of Artificial Intelligence approaches— (i) Reactive 

Machines– These machines are the most basic form of AI applications. 
Examples of reactive machines are games like Deep Blue, IBM’s chess-
playing supercomputer. The AI teams do not use any training sets to 
feed the machines, nor do the later store data for future references. 
Based on the move made by the opponent, the machine decides/
predicts the next move. (ii) Limited Memory– These machines belong 
to the Class II category of AI applications. Self-driven cars are the perfect 
example. These machines are fed with data and are trained with other 
cars’ speed and direction, lane markings, traffic lights, curves of roads, 
and other important factors, over time. (iii) Theory of Mind– Theory 
of mind is the concept where the bots will be able to understand the 
human emotions, thoughts, and how they react to them. If the AI-
powered machines are ever to mingle with us and move around with 
us, understanding human behaviour is imperative. And then, reacting 
to such behaviours accordingly is the requirement. (iv) Self-aware– 
These machines are the extension of the Class III type of AI. It is one 
step ahead of understanding human emotions. This is the phase where 
the AI teams build machines with self-awareness factor programmed in 
them. Building self-aware machines seem far-fetched from where we 
stand today.

E.	 1. Artificial Intelligence, 2. Artificial Narrow Intelligence, 3. Artificial 
General Intelligence, 4. Artificial Super Intelligence, 5. Performance, 
Environment, Actuators, Sensors
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